HP Insight Remote Support Advanced – Unable to install service necessary.

This weekend, I encountered the following error: “Unable to install service necessary to manage products that integrate with HP System Insight Manager. This installation may have future problems managing these updates.”
The error was thrown in version 5.80 with the advanced software.

c03721635

A quick search resulted in this HP Support Document.
Important to note is that in my case, the password did not contain a space, but a semicolon (“;”).

I created a seperate account for the software, tried the installation again and it completed flawlesly.